iFill is a browser based application delivered via a Software as a Service (SaaS) model.

What do you need to use iFill

You need a broadband internet connection. It is recommended that you NOT use iFill if you find yourself using a very slow connection (dialup, cellular networks). If you chose to use iFill with this type of connection you will have difficulty and most likely experience un-intended errors You need a modern, up-to-date web browser. Recommended browsers include:

  • Internet Explorer v9 or higher
  • Google chrome - the most up-to-date version
  • Mozilla Firefox - the most up-to-date version
  • Safari - the most up-to-date version

Operating systems other than Microsoft Windows 7 or higher have not been tested. If you need to use an alternate operating system such as Apple or Linux - you will probably be able to run iFill just fine so long as you are using an appropriate browser version.

Sign up Now

Prescribe with iFill today and your practice will immediately start seeing the benefits.

Sign-up!

See iFill in action

A picture is worth a thousand words so check out our videos and screenshots.